<!DOCTYPE html>

<html class="move" lang="en" dir="ltr"
  xmlns:og="http://ogp.me/ns#"
  xmlns:article="http://ogp.me/ns/article#"
  xmlns:book="http://ogp.me/ns/book#"
  xmlns:profile="http://ogp.me/ns/profile#"
  xmlns:video="http://ogp.me/ns/video#"
  xmlns:product="http://ogp.me/ns/product#"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head profile="http://www.w3.org/1999/xhtml/vocab">
	<meta charset="utf-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<!--[if IE]><![endif]-->
<link rel="dns-prefetch" href="//fonts.gstatic.com" />
<link rel="preconnect" href="//fonts.gstatic.com" crossorigin="" />
<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="preconnect" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//eenews.cdnartwhere.eu" />
<link rel="preconnect" href="//eenews.cdnartwhere.eu" />
<link rel="dns-prefetch" href="//ajax.googleapis.com" />
<link rel="preconnect" href="//ajax.googleapis.com" />
<link rel="dns-prefetch" href="//ws.sharethis.com" />
<link rel="preconnect" href="//ws.sharethis.com" />
<link rel="dns-prefetch" href="//www.google-analytics.com" />
<link rel="preconnect" href="//www.google-analytics.com" />
<link rel="dns-prefetch" href="//stats.g.doubleclick.net" />
<link rel="preconnect" href="//stats.g.doubleclick.net" />
<link rel="dns-prefetch" href="//aka-cdn.adtech.de" />
<link rel="preconnect" href="//aka-cdn.adtech.de" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//eenews.cdnartwhere.eu" />
<!--[if IE 9]>
<link rel="prefetch" href="//eenews.cdnartwhere.eu" />
<![endif]-->
<link rel="next" href="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization/page/0/1" />
<meta name="description" content="Sony Electronics (San Diego, CA) has announced an extensive software update for its autonomous robotic puppy companion, aibo, that allows for further customization and feature enhancements." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="https://www.smart2zero.com/sites/default/files/styles/facebook/public/sites/default/files/images/2019-11-18_sony_aibo_robot_dog_api_programmable_.jpg?itok=xJ5C1Eyt" />
<link rel="shortlink" href="https://www.smart2zero.com/node/123299" />
<meta property="og:site_name" content="Smart2.0" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Sony robotic dog software update opens device to customization" />
<meta property="og:url" content="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" />
<meta property="og:description" content="Sony Electronics (San Diego, CA) has announced an extensive software update for its autonomous robotic puppy companion, aibo, that allows for further customization and feature enhancements." />
<meta property="og:updated_time" content="2019-11-18T17:41:15+01:00" />
<meta property="og:image" content="https://www.smart2zero.com/sites/default/files/styles/facebook/public/sites/default/files/images/2019-11-18_sony_aibo_robot_dog_api_programmable_.jpg?itok=xJ5C1Eyt" />
<meta property="og:image:url" content="https://www.smart2zero.com/sites/default/files/styles/facebook/public/sites/default/files/images/2019-11-18_sony_aibo_robot_dog_api_programmable_.jpg?itok=xJ5C1Eyt" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:url" content="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" />
<meta name="twitter:title" content="Sony robotic dog software update opens device to customization" />
<meta name="twitter:description" content="The software update, Version 2.50 for the ERS1000 aibo model, opens the device to developer customization and feature enhancements. Both U.S. and Japanese aibo owners, says the company, now have access to exciting new programmable resources with the update, as well as several new whimsical capabilities, such as the ability to virtually feed aibo cookies." />
<meta property="article:published_time" content="2019-11-18T17:41:15+01:00" />
<meta property="article:modified_time" content="2019-11-18T17:41:15+01:00" />
			<title>Sony robotic dog software update opens device to customization</title>
		<link type="text/css" rel="stylesheet" href="https://eenews.cdnartwhere.eu/sites/default/files/advagg_css/css__M06IrR64mwFZGUFVW4SZMbZ-MuuHHwEv-XRJ_nZmRQg__0oUjMMSK9y9-lb5BU5JVmOoxbQ_UdCVHb1-4y4ddHj4__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.css" media="all" />
<link type="text/css" rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto+Condensed:400,300,300italic,400italic,700,700italic|Roboto:400,300,300italic,400italic,500,500italic,700,700italic" media="all" />
<link type="text/css" rel="stylesheet" href="https://eenews.cdnartwhere.eu/sites/default/files/advagg_css/css__AnxUe5Cd2adLmDzVBOBvhafs2Hdx1bWnlsEfSVdq42I__nBd0mtuk7Pp-itp4A8euusKEb4yRVfonnjRQuHzJ6mM__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.css" media="all" />
	<!-- HTML5 element support for IE6-8 -->
	<!--[if lt IE 9]>
	<script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->

	<script src="//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>
<script>window.jQuery || document.write("<script src='/sites/all/modules/jquery_update/replace/jquery/1.8/jquery.min.js'>\x3C/script>")</script>
<script src="https://eenews.cdnartwhere.eu/sites/default/files/advagg_js/js__H5AFmq1RrXKsrazzPq_xPQPy4K0wUKqecPjczzRiTgQ__p930YZ_ODW6ZjDLOJmxJnRL7juGStYuszD6uNS8_FFo__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.js"></script>
<script>document.createElement( "picture" );</script>
<script src="https://eenews.cdnartwhere.eu/sites/default/files/advagg_js/js__KOsLoa_6khyM4HvV5fEigpzOc2q7ankR8oQbBPCw0KI__NjB4ORs0uPwmCCgTukQJ6T0TjtH1hKLY5bQ_vcfsXtE__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.js"></script>
<script>var switchTo5x = true;var __st_loadLate = true;</script>
<script defer="defer" src="https://ws.sharethis.com/button/buttons.js"></script>
<script>if (stLight !== undefined) { stLight.options({"publisher":"dr-99d5e654-a5f6-762d-7fc7-d4787a568a1","version":"5x","doNotCopy":true,"hashAddressBar":false,"doNotHash":true}); }</script>
<script src="https://eenews.cdnartwhere.eu/sites/default/files/advagg_js/js__RZCGenkM3V3kdWFlGThY36dty_lb2-g-QTRcUFoNF10__9MvbFM09hKBxfPFia0kCx_c6udqOJb2U2R_JWm5w9jA__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-39051854-2", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");</script>
<script src="//aka-cdn.adtech.de/dt/common/DAC.js"></script>
<script src="//aka-cdn.adtech.de/dac/1649.1/w1199271.js"></script>
<script src="https://eenews.cdnartwhere.eu/sites/default/files/advagg_js/js__1ixyrFjzimM0kAlpaAA5lDfbnuK8Df5J0U_iH0Y-J6k___dGnndrYG5JXUVl4CjgGyGhN85QVdXUbYhqeKftclkc__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.js"></script>
<script>jQuery.extend(Drupal.settings,{"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"eetimes","theme_token":"GR3y1BiZc1bMYPox_gFd7XwteJUYpzr1E5E5zMF8KBM","css":{"modules\/system\/system.base.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"sites\/all\/modules\/date\/date_repeat_field\/date_repeat_field.css":1,"sites\/all\/modules\/domain\/domain_nav\/domain_nav.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/picture\/picture_wysiwyg.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/webform\/css\/webform.css":1,"\/\/fonts.googleapis.com\/css?family=Roboto+Condensed:400,300,300italic,400italic,700,700italic|Roboto:400,300,300italic,400italic,500,500italic,700,700italic":1,"sites\/all\/themes\/eetimes\/css\/bootstrap.min.css":1,"sites\/all\/themes\/eetimes\/css\/style.css":1,"sites\/all\/themes\/eetimes\/css\/cookie.css":1,"sites\/all\/themes\/eetimes\/css\/switchery.min.css":1,"sites\/all\/themes\/eetimes\/css\/bootstrap-multiselect.css":1},"js":{"sites\/all\/modules\/picture\/picturefill2\/picturefill.min.js":1,"sites\/all\/modules\/picture\/picture.min.js":1,"sites\/all\/themes\/eetimes\/js\/jquery.cookie.js":1,"sites\/all\/themes\/eetimes\/js\/switchery.min.js":1,"sites\/all\/themes\/eetimes\/js\/cookie.js":1,"sites\/all\/themes\/bootstrap\/js\/bootstrap.js":1,"\/\/ajax.googleapis.com\/ajax\/libs\/jquery\/1.8.3\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/smart_paging\/js\/smart_paging-pager.js":1,"sites\/all\/modules\/nodeviewcount\/theme\/js\/nodeviewcount.js":1,"https:\/\/ws.sharethis.com\/button\/buttons.js":1,"misc\/textarea.js":1,"sites\/all\/modules\/webform\/js\/webform.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"\/\/aka-cdn.adtech.de\/dt\/common\/DAC.js":1,"\/\/aka-cdn.adtech.de\/dac\/1649.1\/w1199271.js":1,"sites\/all\/themes\/eetimes\/js\/bootstrap.min.js":1,"sites\/all\/themes\/eetimes\/js\/unveil.js":1,"sites\/all\/themes\/eetimes\/js\/jquery.mobile.custom.min.js":1,"sites\/all\/themes\/eetimes\/js\/jquery.menu-aim.js":1,"sites\/all\/themes\/eetimes\/js\/bootstrap-multiselect.js":1,"sites\/all\/themes\/eetimes\/js\/script.js":1}},"smart_paging":{"first_element":0,"current_page":0,"base_url":"https:\/\/www.smart2zero.com","current_url":"news\/sony-robotic-dog-software-update-opens-device-customization","path_prefix":"page","custom_url_page":[]},"nodeviewcount":{"nodeviewcount_path":"nodeviewcount","nodeviewcount_nid":"123299","nodeviewcount_uid":0},"urlIsAjaxTrusted":{"\/news\/sony-robotic-dog-software-update-opens-device-customization":true},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"bootstrap":{"anchorsFix":1,"anchorsSmoothScrolling":1,"popoverEnabled":1,"popoverOptions":{"animation":1,"html":0,"placement":"right","selector":"","trigger":"click","title":"","content":"","delay":0,"container":"body"},"tooltipEnabled":1,"tooltipOptions":{"animation":1,"html":0,"placement":"auto left","selector":"","trigger":"hover focus","delay":0,"container":"body"}}});</script>

		<script src="https://cdn.jsdelivr.net/npm/mobile-detect@1.4.3/mobile-detect.min.js"></script>
		
		<script type="text/javascript">
			var md = new MobileDetect(window.navigator.userAgent);
			(function(d, s, e, t) {
				e = d.createElement(s);
				e.type = 'text/java' + s;
				e.async = 'async';
				e.src = 'http' + ('https:' === location.protocol ? 's' : '') + '://cdn.adnuntius.com/adn.js';
				t = d.getElementsByTagName(s)[0];
				t.parentNode.insertBefore(e, t);
			})(document, 'script');
			window.adn = window.adn || {};
			adn.calls = adn.calls || [];
		</script>
			<script type="text/javascript">
				if(md.mobile()!=null) {
					adn.calls.push(function() {
						adn.request({
							adUnits: [{"auId":"000000000006608d","auW":"1","auH":"1"},{"auId":"000000000006608d","auW":"300","auH":"250"},{"auId":"000000000006608c","auW":"1","auH":"1"},{"auId":"000000000006608c","auW":"300","auH":"250"},{"auId":"000000000006608b","auW":"1","auH":"1"},{"auId":"000000000006608b","auW":"300","auH":"250"}]
						});
					});
				}
				else {
					adn.calls.push(function() {
            adn.request({
                adUnits: [{"auId":"0000000000066084","auW":"300","auH":"250"},{"auId":"0000000000066086","auW":"1","auH":"1"},{"auId":"0000000000066086","auW":"300","auH":"250"},{"auId":"0000000000066085","auW":"1","auH":"1"},{"auId":"0000000000066085","auW":"300","auH":"250"},{"auId":"0000000000066088","auW":"1","auH":"1"},{"auId":"0000000000066088","auW":"728","auH":"90"},{"auId":"0000000000066082","auW":"728","auH":"90"},{"auId":"0000000000066087","auW":"1","auH":"1"},{"auId":"0000000000066087","auW":"300","auH":"250"},{"auId":"000000000006608a","auW":"1","auH":"1"},{"auId":"000000000006608a","auW":"160","auH":"600"},{"auId":"0000000000066083","auW":"1","auH":"1"},{"auId":"0000000000066083","auW":"940","auH":"170"},{"auId":"0000000000066081","auW":"1","auH":"1"}]
            });
        });
				}
			</script></head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-123299 node-type-article domain-smart2zero i18n-en"  style="z-index:999">
<div id="skip-link">
	<a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
</div>

<script>
var cpt = 0;
var intv = setInterval(function() {
if($("body").css("background-image") != "none") {
$("body").addClass('wallpaperAds');
}
cpt++;
if(cpt>20) clearInterval(intv);
},300);
</script>
<div id="adn-0000000000066081" style="display: none"></div><header id="navbar" role="banner" class="navbar navbar-default"><div class="container"><div class="col-sm-4"><a class="logo navbar-btn pull-left" href="/" title="Home"><img src="https://eenews.cdnartwhere.eu/sites/all/themes/eetimes/images/logo/logo-9.png" alt="Home" /></a><div id="social-mob"><a href="https://www.facebook.com/smart2zero" target="_blank" class="fb"></a><a href="https://twitter.com/Smart2Zero" target="_blank" class="tw"></a></div><ul class="menu nav navbar-nav pull-right secondary"><li><a role="button" data-toggle="modal" data-target="#login-modal" href="#">Login</a></li><li><a data-target="/user/register" data-toggle="modal" href="#">Register</a></li></ul><div class="hidden-search-input"><form accept-charset="UTF-8" id="header-search-form2" method="post" action="/search/node/"> <input type="search" name="query" id="header-search-form-input" placeholder="Search" /><div class="search-btn"> <a href="#"> <span> </span> </a></div></form></div></div><div class="col-sm-8"><div class="banner-top"><div id="adn-0000000000066082" style="display: none"></div></div></div></div><div class="main-menu-zone"><div class="main-menu-content"><div class="container"><div class="navbar-header"><button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-collapse"><span class="sr-only">Toggle navigation</span><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span></button></div><div class="navbar-collapse collapse"><nav role="navigation"><ul class="nav navbar-nav"><li class="item-1599 first expanded"><a href="/about-smart2zero"><span>About</span></a><div class="submenu-content about"><div class="design-centers">About</div><ul class="sub-menu"><li class="first leaf"><a href="/about-smart2zero">About Smart2Zero</a></li><li class="leaf"><a href="/s2z-sales-contacts">Sales Contacts</a></li><li class="leaf"><a href="/main-office-contacts-smart2zero">Main Office Contacts</a></li><li class="leaf"><a href="/media-kit-smart2zero">Media Kit</a></li><li class="last leaf"><a href="/content/production-contacts">Production Contacts</a></li></ul></div></li><li class="item-1606 expanded"><a href="/news"><span>News</span></a><div class="submenu-content news"><div class="design-centers">News</div><ul class="sub-menu"><li class="first leaf"><a href="/news-s2z/3D Printing">3D Printing</a></li><li class="leaf"><a href="/news-s2z/Blog">Blog</a></li><li class="leaf"><a href="/news-s2z/Connected car">Connected car</a></li><li class="leaf"><a href="/news-s2z/Electric Vehicles">Electric Vehicles</a></li><li class="leaf"><a href="/news-s2z/Energy Harvesting">Energy Harvesting</a></li><li class="last leaf"><a href="/news-s2z/Home Automation">Home Automation</a></li></ul></div></li><li class="item-1620 expanded"><a href="/events"><span>Events</span></a><div class="submenu-content events"><div class="design-centers">Events</div><ul class="sub-menu"><li class="first leaf"><a href="/events/Exhibitions">Exhibitions</a></li><li class="leaf"><a href="/events/Seminars">Seminars</a></li><li class="leaf"><a href="/events/Workshops">Workshops</a></li><li class="last leaf"><a href="/events/Webinars">Webinars</a></li></ul></div></li><li class="item-1629 last expanded"><a href="/Learning-center"><span>Learning center</span></a><div class="submenu-content learning center"><div class="design-centers">Learning center</div><ul class="sub-menu"><li class="first leaf"><a href="/Learning-center">White Papers</a></li><li class="last leaf"><a href="/content/webinars">Webinars</a></li></ul></div></li></ul><div class="hidden-search-input"><form accept-charset="UTF-8" id="header-search-form" method="post" action="/search/node/"><input type="search" name="query" id="header-search-form-input" placeholder="Search" /><div class="search-btn"><a href='javascript:jQuery("#header-search-form").submit();'><span> </span></a></div></form></div></nav></div></div></div><div class="submenu-content"><div class="container"><div class="row"><div class="col-xs-12"><div class="col-sm-12 col-xs-12 no-pad"><div class="main-sub"></div><div class="js-sub"></div></div><div class="col-sm-12 col-xs-12 soc-mob"><ul class="menu nav navbar-nav pull-right secondary"><li><a id="login-btn" href="/user">Login</a></li><li><a href="/user/register">Register</a></li></ul></div></div></div></div></div></div></header><div id="adn-0000000000066081" style="display: none"></div><div id="social-flot"><a href="https://twitter.com/Smart2Zero" target="_blank" class="tw"></a></div><div class="main-container container"> <header role="banner" id="page-header"> </header> <section class="ads-imu-home-mob"></section><div class="row"><div class="supBanner"><div id="adn-0000000000066083" style="display: none"></div><br/></div> <section class="col-sm-8"><div class="hidden-xs hidden-sm col-md-3 hidden-print" style="padding:0;"><div id="adn-000000000006608a" style="display: none"></div></div><div class="col-sm-12 col-md-9" id="main-col"><div class="highlighted jumbotron"></div> <a id="main-content"></a><h1>Sony robotic dog software update opens device to customization</h1>
<script type="text/javascript">
var disqus_shortname = "eetimes";
(function () {
var s = document.createElement("script"); s.async = true;
s.type = "text/javascript";
s.src = "//" + disqus_shortname + ".disqus.com/count.js";
(document.getElementsByTagName("HEAD")[0] || document.getElementsByTagName("BODY")[0]).appendChild(s);
}());
</script>
<a href="#dsq-app1" class="disqus-comment-count" style="float:right;color:#cb242e;" data-disqus-url="http://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization"></a><div class="author"><span>November 18, 2019</span> //<span>By Rich Pell</span></div><div class="region region-content"><section id="block-system-main" class="block block-system clearfix"><div id="node-123299" class="node node-article clearfix" about="/news/sony-robotic-dog-software-update-opens-device-customization" typeof="sioc:Item foaf:Document"> <span property="dc:title" content="Sony robotic dog software update opens device to customization" class="rdf-meta element-hidden"></span><div class="content"><div class="sharethis-buttons"><div class="sharethis-wrapper"><span st_url="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" st_title="Sony robotic dog software update opens device to customization" class="st_email_button" displayText="email"></span><span st_url="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" st_title="Sony robotic dog software update opens device to customization" class="st_print_button" displayText="print"></span><span st_url="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" st_title="Sony robotic dog software update opens device to customization" class="st_facebook_button" displayText="facebook"></span><span st_url="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" st_title="Sony robotic dog software update opens device to customization" class="st_linkedin_button" displayText="linkedin"></span><span st_url="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" st_title="Sony robotic dog software update opens device to customization" class="st_reddit_button" displayText="reddit"></span><span st_url="https://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization" st_title="Sony robotic dog software update opens device to customization" class="st_plusone_button" displayText="plusone"></span></div></div><div class="field field-name-field-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="og:image rdfs:seeAlso" resource="https://eenews.cdnartwhere.eu/sites/default/files/styles/inner_article/public/sites/default/files/images/2019-11-18_sony_aibo_robot_dog_api_programmable_.jpg?itok=5YaW0Q0i"><img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/inner_article/public/sites/default/files/images/2019-11-18_sony_aibo_robot_dog_api_programmable_.jpg?itok=5YaW0Q0i" width="595" height="347" alt="Sony robotic dog software update opens device to customization" /></div></div></div><div class="field field-name-field-header field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even">Sony Electronics (San Diego, CA) has announced an extensive software update for its autonomous robotic puppy companion, aibo, that allows for further customization and feature enhancements.</div></div></div><div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>The software update, Version 2.50 for the ERS1000 aibo model, opens the device to developer customization and feature enhancements. Both U.S. and Japanese aibo owners, says the company, now have access to exciting new programmable resources with the update, as well as several new whimsical capabilities, such as the ability to virtually feed aibo cookies.</p><p>"As a longtime innovator and leader in the companion robot space, Sony is committed to working towards ongoing advancements and enhancements in A.I. and robotics technologies," says Michiko Araki Kelley, vice president, New Business and Corporate Marketing Group, Sony Electronics North America. "Software updates like Version 2.50 help to improve the aibo user experience, and also continue to help lead the A.I. and robotics conversation into the future."</p><p>The Version 2.50 software update introduces a new aibo Web-based application programming interface (API), which provides owners access to both the " <a href="https://us.aibo.com/developer/">aibo Developer Program </a>" for more seasoned developers and the " <a href="https://us.aibo.com/fan/visual_programming/">aibo Visual Programming </a>" for beginner programmers. Provided free of charge, the Web-based API allows owners to program aibo's actions, although not its emotions, character, or moods.</p><p>With the aibo Developer Program, the company says it is looking to developers to continue building on aibo's abilities and create greater possibilities for aibo in the future. It is a licensing program accessible to any aibo owner with the desire to create new applications, traits, and experiences for aibo.</p><p>Developers can utilize the program to create services and applications that can be linked with aibo. The mechanism of this API is the same as a general REST API, and it can be implemented in almost any system with an Internet environment.</p><p>The easy-to-use aibo Visual Programming tool allows owners to create original movements and tricks for aibo using a drag and drop block coding user interface for beginners. By encouraging programming and development through the Web API, the company says it aims to expand and promote</p></div></div></div><div class="smart-paging-pager"><div class="text-center"><ul class="pagination"><li class="active first"><a href="#">1</a></li><li><a title="Go to page 2" href="/news/sony-robotic-dog-software-update-opens-device-customization/page/0/1">2</a></li><li class="next last"><a href="/news/sony-robotic-dog-software-update-opens-device-customization/page/0/1">next</a></li></ul></div></div></div></div></section></div><div style="width:100%"></div><br /><div class="col-sm-12 hidden-print" style="margin-top: 20px;margin-left: -195px;float:right;padding-right:0;"><div id="LEADERBOARD_MIDDLE" style="float:right;"><div id="adn-0000000000066088" style="display: none"></div></div></div><div id="disqus_thread"></div>
<script>
var disqus_config = function () {
this.page.url = "http://www.smart2zero.com/news/sony-robotic-dog-software-update-opens-device-customization";  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = 123299; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};
(function() {
var d = document, s = d.createElement('script');
s.src = '//eetimes.disqus.com/embed.js';
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<div class="ads-imu-home-mob col-sm-12"><div id="adn-000000000006608b" style="display: none"></div></div></div><div class="col-sm-12 hidden-print" style="overflow: hidden;margin-top: 20px;"><div class="view view-related-news view-id-related_news view-display-id-block view-dom-id-e7e418b43d543da736939c3ffc1b0f01"><div class="view-content"><div class="col-sm-6"><div class="newstile"><div class="news-header-img"> <a href="/news/e-paper-film-print-technology-opens-door-lower-cost-iot-displays"> <img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/home_news/public/sites/default/files/images/2019-08-19-jh-e-ink.jpg?itok=_cuCQvs7" alt="E-paper film print technology opens door to lower cost IoT displays" /> </a></div><div class="news-header"><div class="news-header-title"> <a href="/news/e-paper-film-print-technology-opens-door-lower-cost-iot-displays"><h4>E-paper film print technology opens door to lower-cost IoT displays</h4></a></div><div class="news-header-infos"> <span class="news-cat">Technology News</span> | <span class="news-date">Aug 21,2019</span></div></div></div></div><div class="col-sm-6"><div class="newstile"><div class="news-header-img"> <a href="/news/video-codec-standard-machines-proposed"> <img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/home_news/public/images/01-picture-library/JPJoosting/Generic/robotics-m2m-web.jpg?itok=ibuRVkwS" alt="" /> </a></div><div class="news-header"><div class="news-header-title"> <a href="/news/video-codec-standard-machines-proposed"><h4>Video codec standard for machines proposed</h4></a></div><div class="news-header-infos"> <span class="news-cat">Technology News</span> | <span class="news-date">Aug 21,2019</span></div></div></div></div><div class="ads-imu-home-mob col-sm-12"></div><div class="col-sm-6"><div class="newstile"><div class="news-header-img"> <a href="/news/video-codec-standard-machines-proposed"> <img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/home_news/public/images/01-picture-library/JPJoosting/Generic/robotics-m2m-web.jpg?itok=ibuRVkwS" alt="" /> </a></div><div class="news-header"><div class="news-header-title"> <a href="/news/video-codec-standard-machines-proposed"><h4>Video codec standard for machines proposed</h4></a></div><div class="news-header-infos"> <span class="news-cat">Technology News</span> | <span class="news-date">Aug 21,2019</span></div></div></div></div><div class="col-sm-6"><div class="newstile"><div class="news-header-img"> <a href="/news/video-codec-standard-machines-proposed"> <img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/home_news/public/images/01-picture-library/JPJoosting/Generic/robotics-m2m-web.jpg?itok=ibuRVkwS" alt="" /> </a></div><div class="news-header"><div class="news-header-title"> <a href="/news/video-codec-standard-machines-proposed"><h4>Video codec standard for machines proposed</h4></a></div><div class="news-header-infos"> <span class="news-cat">Technology News</span> | <span class="news-date">Aug 21,2019</span></div></div></div></div><div class="col-sm-6"><div class="newstile"><div class="news-header-img"> <a href="/news/video-codec-standard-machines-proposed"> <img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/home_news/public/images/01-picture-library/JPJoosting/Generic/robotics-m2m-web.jpg?itok=ibuRVkwS" alt="" /> </a></div><div class="news-header"><div class="news-header-title"> <a href="/news/video-codec-standard-machines-proposed"><h4>Video codec standard for machines proposed</h4></a></div><div class="news-header-infos"> <span class="news-cat">Technology News</span> | <span class="news-date">Aug 21,2019</span></div></div></div></div><div class="col-sm-6"><div class="newstile"><div class="news-header-img"> <a href="/news/video-codec-standard-machines-proposed"> <img typeof="foaf:Image" src="https://eenews.cdnartwhere.eu/sites/default/files/styles/home_news/public/images/01-picture-library/JPJoosting/Generic/robotics-m2m-web.jpg?itok=ibuRVkwS" alt="" /> </a></div><div class="news-header"><div class="news-header-title"> <a href="/news/video-codec-standard-machines-proposed"><h4>Video codec standard for machines proposed</h4></a></div><div class="news-header-infos"> <span class="news-cat">Technology News</span> | <span class="news-date">Aug 21,2019</span></div></div></div></div></div></div></div> </section> <aside class="col-sm-4" role="complementary"><div class="region region-sidebar-first"> <section class="ads-imu-home"><div id="adn-0000000000066084" style="display: none"></div> </section> <section id="block-views-most-recent-articles-block" class="block block-views contextual-links-region clearfix"><h3 class="red fill">Most recent articles <a href="/news" class="arrow-btn"></a></h3><ol><div class="view view-most-recent-articles view-id-most_recent_articles view-display-id-block view-dom-id-bb3b7ff2881f39807ebeb1388ad2fb15"><div class="view-content"><li><a href="/news/sony-robotic-dog-software-update-opens-device-customization">Sony robotic dog software update opens device to customization</a></li><li><a href="/news/how-google-can-compete-apple-wearables">How Google can compete with Apple in wearables</a></li><li><a href="/news/tunable-terahertz-laser-promises-t-ray-vision-room-temps">Tunable terahertz laser promises &#039;T-ray vision&#039; at room temps</a></li><li><a href="/news/digital-electricity-startup-looks-scale-power-offerings-buildings">&#039;Digital electricity&#039; startup looks to scale power offerings to buildings</a></li><li><a href="/news/ai-chip-high-performance-low-power-edge-processing">AI chip for high-performance, low-power edge processing</a></li><div id="adn-0000000000066087" style="display: none"></div><li><a href="/news/solar-cell-concept-combines-best-different-worlds">Solar cell concept combines the best of different worlds</a></li><li><a href="/news/vw-spend-eu60-billion-electromobility-digitisation-rd">VW to spend €60 billion for electromobility, digitisation R&amp;D</a></li><li><a href="/news/check-point-acquires-groundbreaking-device-iot-security-technology">Check Point acquires &#039;groundbreaking&#039; on-device IoT security technology</a></li><li><a href="/news/compute-architecture-achieves-1-petaops-single-chip">Compute architecture achieves 1 PetaOp/s on a single chip</a></li><li><a href="/news/gartner-software-progress-drives-autonomy-cars">Gartner: Software progress drives autonomy of cars</a></li></div></div></ol> </section> <section class="ads-imu-home"><div id="adn-0000000000066085" style="display: none"></div> </section> <section id="block-views-most-read-articles-block" class="block block-views contextual-links-region clearfix"><h3 class="red fill">Most read <a href="/news" class="arrow-btn"></a></h3><ol><div class="view view-most-read-articles view-id-most_read_articles view-display-id-block view-dom-id-237af7ce5a45591cb085ebcfaff44ade"><div class="view-content"><li> <a href="/news/compute-architecture-achieves-1-petaops-single-chip">Compute architecture achieves 1 PetaOp/s on a single chip</a></li><li> <a href="/news/supercomputer-based-weather-forecasting-system-rolls-out-worldwide">Supercomputer-based weather forecasting system rolls out worldwide</a></li><li> <a href="/news/nanostructures-out-3d-printer">Nanostructures out of the 3D printer </a></li><li> <a href="/news/computer-vision-platform-creates-intelligent-3d-twin-any-building">Computer vision platform creates intelligent 3D twin of any building</a></li><li> <a href="/news/vw-spend-eu60-billion-electromobility-digitisation-rd">VW to spend €60 billion for electromobility, digitisation R&amp;D</a></li><li> <a href="/news/gartner-software-progress-drives-autonomy-cars">Gartner: Software progress drives autonomy of cars</a></li><li> <a href="/news/bacteria-biosensors-detect-underground-explosives">Bacteria biosensors to detect underground explosives</a></li><li> <a href="/news/battery-management-tech-measures-electrochemical-impedance">Battery management tech measures electrochemical impedance</a></li><li> <a href="/news/ai-chip-startup-emerges-offering-next-gen-computing-architecture">AI chip startup emerges offering next-gen computing architecture</a></li><li> <a href="/news/mixed-reality-tech-yields-interactive-holographic-brain-atlas">Mixed-reality tech yields interactive holographic brain &#039;atlas&#039;</a></li></div></div></ol> </section><section class="ads-imu-home"><div id="adn-0000000000066086" style="display: none"></div></section><section id="block-views-most-recent-whitepaper-block" class="block block-views contextual-links-region clearfix"><h3 class="red fill">Technical Papers <a href="/Learning-center" class="arrow-btn"></a></h3><ol><div class="view view-most-recent-articles view-id-most_recent_articles view-display-id-tech view-dom-id-5e0ec4f00ae6c650b0d2a25c0d70eec0"><div class="view-content"><li><a href="/Learning-center/how-do-machine-learning-arm-cortex-m-microcontrollers">How To Do Machine Learning on Arm Cortex-M Microcontrollers</a></li><li><a href="/Learning-center/how-migrate-intelligence-cloud-embedded-devices-edge">How To Migrate Intelligence From the Cloud To Embedded Devices At the Edge</a></li><li><a href="/Learning-center/designing-iot-intelligence-moves-edge">Designing for the IoT as Intelligence Moves to the Edge</a></li><li><a href="/Learning-center/avnet-silica-and-semiconductor-designing-iot-intelligence-moves-edge-0">Avnet Silica and ON Semiconductor - Designing for the IoT as Intelligence Moves to the Edge</a></li><li><a href="/Learning-center/avnet-silica-and-semiconductor-decreasing-time-design-industrial-internet-things">Avnet Silica and ON Semiconductor - Decreasing Time to Design in the Industrial Internet of Things</a></li><li><a href="/Learning-center/avnet-silica-and-semiconductor-designing-iot-intelligence-moves-edge">Avnet Silica and ON Semiconductor - Designing for the IoT as Intelligence Moves to the Edge</a></li><li><a href="/Learning-center/mouser-establishing-root-trust-secure-iot">Mouser - Establishing a root of trust to secure the IoT </a></li><li><a href="/Learning-center/espros-match-tof-sensor-your-car-application">Espros: Match the TOF sensor with your car application </a></li><li><a href="/Learning-center/pentek-critical-techniques-high-speed-ad-converters-real-time-systems">Pentek: Critical Techniques for High-Speed A/D Converters in Real-Time Systems </a></li><li><a href="/Learning-center/i-pex-connectors-answering-demand-smart-car-connectivity">I-PEX Connectors: Answering the Demand for Smart Car Connectivity</a></li></div></div></ol></section></div> </aside></div></div><div class="modal fade" id="imagemodal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true"><div class="modal-dialog"><div class="modal-content"><div class="modal-header"><button type="button" class="close" data-dismiss="modal"><span aria-hidden="true">&times;</span><span class="sr-only">Close</span></button><h4 class="modal-title" id="myModalLabel">Image preview</h4></div><div class="modal-body"><img src="" id="imagepreview" ></div><div class="modal-footer"><button type="button" class="btn btn-default" data-dismiss="modal">Close</button></div></div></div></div><footer class="footer"><div class="container"><div class="row"><div class="col-lg-10 col-lg-offset-1"><div class="row"><div class="col-sm-6 footer-menu"><div class="row"><div class="col-xs-4"> MEDIA KIT<ul class="links"><li><a class="menu-649" href="/content/media-kit"><span>eeNews Media Data</span></a></li><li><a class="menu-656" href="/media-kit-eenews-embedded"><span>eeNews Embedded</span></a></li><li><a class="menu-650" href="/media-kit/eete-white-papers"><span>eeNews White Papers</span></a></li><li><a class="menu-2081" href="/mwee-media-kit"><span>MWEE Media Kit</span></a></li><li><a class="menu-2223" href="/media-kit-smart2zero"><span>Smart2zero Media kit</span></a></li><li><a class="menu-654" href="/media-kit/eetsearch"><span>EETsearch</span></a></li><li><a class="menu-655" href="/media-kit/eci-media-data"><span>ECI - France</span></a></li><li><a class="menu-652" href="/media-kit/list-rental"><span>List Rental</span></a></li></ul></div><div class="col-xs-4"> DESIGN<ul class="links"><li class="menu-1011 first"><a href="https://www.eenewseurope.com">eeNews Europe</a></li><li class="menu-2280"><a href="https://www.eenewsembedded.com">eeNews Embedded</a></li><li class="menu-659"><a href="https://www.eenewsanalog.com/" target="_blank">eeNews Analog</a></li><li class="menu-660"><a href="https://www.eenewsautomotive.com/" target="_blank">eeNews Automotive</a></li><li class="menu-661"><a href="https://www.eenewsled.com/" target="_blank">eeNews LEDLighting</a></li><li class="menu-658"><a href="https://www.eenewspower.com/" target="_blank">eeNews Power </a></li><li class="menu-662"><a href="https://www.eenewstest.com/" target="_blank">eeNews Test</a></li><li class="menu-936"><a href="https://www.mwee.com">Microwave</a></li><li class="menu-1751"><a href="https://www.electronique-eci.com/">Electronique-ECI</a></li><li class="menu-1750 last"><a href="https://www.smart2zero.com">Smart2Zero</a></li></ul></div><div class="col-xs-4"> eeNews Europe NETWORK<ul class="links"><li class="menu-665 first last"><a href="https://www.embedded-world.eu" target="_blank">EmbeddedWorld Nuremberg</a></li></ul></div></div><div class="row"><div class="col-xs-12 footer-text"><p>All material on this site Copyright © 2017 European Business Press SA. All rights reserved.</p></div></div></div><div class="col-sm-6"><div class="row"><div class="col-xs-12 black-btn"><ul class="links"><li class="menu-683 first"><a href="https://www.mwee.com/">Microwave and RF</a></li><li class="menu-681"><a href="https://www.eenewseurope.com/newsletters">Newsletter</a></li><li class="menu-684"><a href="https://www.eetsearch.com/">Product Search</a></li><li class="menu-682 last"><a href="/magazine/subscription">Subscribe</a></li></ul></div></div></div></div></div></div></div><div class="footer-submenu"><div class="container"><div class="row"><div class="col-lg-10 col-lg-offset-1"><div class="row"><div class="col-xs-12"><ul class="links"><li class="menu-687 first"><a href="/contact">Contact</a></li><li class="menu-688"><a href="/rss.xml">RSS</a></li><li class="menu-689"><a href="/search/node">Search</a></li><li class="menu-690 last"><a href="/content/privacy-statement">Privacy Statement</a></li></ul></div></div></div></div></div></div><div class="container"><div class="row"><div class="col-lg-10 col-lg-offset-1"><div class="row"><div class="col-xs-12"><div class="signature pull-right"> <a href="https://www.artwhere.be"><span>ArtWhere</span> Création de site Internet</a></div></div></div></div></div></div></footer><div id="bottomFixed"></div>
<script>
if(jQuery(window).width() <= 700 ) {
jQuery(".ads-imu-home").remove();
} else {
jQuery(".ads-imu-home-mob").remove();
}
ADTECH.enqueueAd(6014502);ADTECH.enqueueAd(6014500);ADTECH.enqueueAd(6014503);ADTECH.enqueueAd(6014510);ADTECH.enqueueAd(6014509);ADTECH.enqueueAd(6216581);ADTECH.enqueueAd(6014499);ADTECH.enqueueAd(6014501);ADTECH.enqueueAd(6014504);ADTECH.enqueueAd(6014505);ADTECH.enqueueAd(6014506);ADTECH.enqueueAd(6014507);ADTECH.enqueueAd(6014508);ADTECH.enqueueAd(6014511);ADTECH.enqueueAd(6014512);ADTECH.enqueueAd(6014513);ADTECH.enqueueAd(6389152);ADTECH.enqueueAd(6644372);ADTECH.enqueueAd(6648510);ADTECH.enqueueAd(6649549);ADTECH.executeQueue();</script><script src="https://eenews.cdnartwhere.eu/sites/default/files/advagg_js/js__Dx87WVqe4v5JxdO5NQXWuqi4N2DXrrivAJ5F7KUcBCY__qAl84FcCv2jyN22yFGS5Oc85cjd9zKX6p_cFNLGhe-M__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.js" async="async"></script>
<script src="https://eenews.cdnartwhere.eu/sites/default/files/advagg_js/js__916gIalIK_ck5CqMG5E08BazaBWsFq3B1RA5GS4Bkzs__HiZDka43xbhp9_VMB09uS73e0a46ky38iQMebuBcULo__mXcD8oEp7uQuYmi5GK_2E0PwgSxPPge-IKbM0gFaxio.js"></script>


<section id="acc-bottom" style="display:none">
  <div class="acc-btn">
      <div class="triangle">
          <span> This site uses cookies to enhance your visitor experience. By continuing your visit to this site, you accept the use of cookies to offer services and offers tailored to your interests (<a href="/content/privacy-statement">see our Privacy & Data Protection Policy</a>).</span>
          <div class="btn-content"><a href="#" class="yes">I understand</a> <a href="/content/privacy-statement?cookie=ee" class="no">Edit</a></div>
      </div>
      <div class="cookie"></div>
  </div>
</section>
<section id="acc">

        <div id="acc-overlay"></div>

        <div id="acc-popup" class="">
            <div class="acc-close "></div>
            <h2 class="acc-title">Vous êtes certain ?</h2>
            <p>
                Si vous désactivez les cookies, vous ne pouvez plus naviguer sur le site.
            </p>
            <p>
                Vous allez être rediriger vers Google.
            </p>
            <div id="popup-btn-container">
                <a class="acc-button closePopup" href="#">Annuler</a>
                <a class="acc-button leaveWebsite" href="#">Quitter</a>
            </div>
        </div>

        <div id="acc-block">

            <div id="acc-btn">
                <div id="triangle">

                </div>
                <div id="cookie"></div>
            </div>

            <div id="acc-aside">

                <form autocomplete="off" id="gdpr_cookie" data-drupal-form-fields="">

					<div class="acc-close"></div>

                    <!-- ACC INTRO -->

                    <h2 class="acc-title">This site use Cookies</h2>



                    <hr>
                    <div class="acc-close"></div>
						<div class="checkbox-container">
							<h3>Essential cookies</h3>
							   <div class="acc-checkbox">
									<label>
																			</label>
								</div>
								<p>
								These cookies are required to navigate on our Site. They allow us to analyse our traffic. If you
								disable cookies, you can no longer browse the site. You can of course change the setting
								</p>
						</div>
						<hr>

						<div class="checkbox-container">
							<h3>Advertising cookies</h3>
							   <div class="acc-checkbox">
									<label>
										<input name="cookies de publicité" type="checkbox" class="acc-check" data-switchery="true" >
									</label>
								</div>
								<p>
								
								</p>
						</div>
						<hr>
						

						
						<div class="checkbox-container">
							<h3>Analytical Cookies</h3>
							   <div class="acc-checkbox">
									<label>
										<input name="cookies analytiques" type="checkbox" class="acc-check" data-switchery="true" >
									</label>
								</div>
								<p>
									These cookies are used to gather information about your use of the Site to improve your access to
									the site and increase its usability.
								</p>
						</div>
						<hr>
						
						
						<div class="checkbox-container">
							<h3>Third party cookies</h3>
							   <div class="acc-checkbox">
									<label>
										<input name="cookies tiers" type="checkbox" class="acc-check" data-switchery="true" >
									</label>
								</div>
								<p>
									These cookies allow you to share your favourite content of the Site with other people via social
									networks. Some sharing buttons are integrated via third-party applications that can issue this type of
									cookies. This is particularly the case of the buttons &quot;Facebook&quot;, &quot;Twitter&quot;, &quot;Linkedin&quot;. Be careful, if
									you disable it, you will not be able to share the content anymore. We invite you to consult the
									privacy policy of these social networks.
								</p>
						</div>
						
						<div class="acc-alert" style="">
							<h4>Pay attention, some cookies cannot be removed</h4>
							<p>
								To cancel some cookies, please follow the procedures on the following links
							</p>
							<p>

								<a target="_blank" href="http://www.addthis.com/privacy/opt-out">
									AddThis
								</a>
								<br>
							
								<br>
							</p>
						</div>
						<hr>
                    <p class="last-p">
                         <a href="http://www.artwhere.be" target="_blank" style="text-decoration: none">About this tool</a>
                    </p>

                    <div id="submit-content">
                        <button class="acc-button">Save</button>
                    </div>

                </form>

            </div>
        </div>

    </section>
</body>
</html>

<!-- Page cached by Boost @ 2019-11-18 19:58:18, expires @ 2019-11-18 20:58:18, lifetime 1 hour -->